Congestion Avoidance and Control
This paper is under a licence that does not allow it to be reproduced, so what is here is its front matter and a short abstract. Read it at the publisher's page.
Michael J. Karels‡ University of California at Berkeley
November, 1988
Tránh tắc nghẽn và điều khiển*
Van Jacobson† Lawrence Berkeley Laboratory
Michael J. Karels‡ University of California at Berkeley
Tháng 11, 1988
Các mạng máy tính đã trải qua sự tăng trưởng bùng nổ trong vài năm qua và cùng với sự tăng trưởng đó đã xuất hiện các vấn đề tắc nghẽn nghiêm trọng. Ví dụ, hiện nay việc thấy các gateway internet loại bỏ 10% các gói tin đầu vào do tràn bộ đệm cục bộ là điều phổ biến. Nghiên cứu của chúng tôi về một số vấn đề này đã chỉ ra rằng phần lớn nguyên nhân nằm trong các triển khai giao thức truyền tải (không phải trong bản thân các giao thức): Những cách ‘hiển nhiên’ để triển khai một giao thức truyền tải dựa trên cửa sổ có thể dẫn đến đúng kiểu hành vi sai trong phản ứng với tắc nghẽn mạng. Chúng tôi đưa ra các ví dụ về hành vi ‘sai’ và mô tả một số thuật toán đơn giản có thể được sử dụng để khiến những điều đúng xảy ra. Các thuật toán bắt nguồn từ ý tưởng đạt được sự ổn định của mạng bằng cách buộc kết nối truyền tải tuân theo một nguyên lý ‘bảo toàn gói tin’. Chúng tôi chỉ ra cách các thuật toán được suy ra từ nguyên lý này và ảnh hưởng của chúng đối với lưu lượng trên các mạng bị tắc nghẽn.
Introduction
This section is missing here.
1 GETTING TO EQUILIBRIUM: SLOW-START
This section is missing here.
2 CONSERVATION AT EQUILIBRIUM: ROUND-TRIP TIMING
This section is missing here.
3 ADAPTING TO THE PATH: CONGESTION AVOIDANCE
This section is missing here.
4 THE GATEWAY SIDE OF CONGESTION CONTROL
This section is missing here.
Acknowledgments
This section is missing here.
A A fast algorithm for rtt mean and variation
This section is missing here.
B SLOW-START + CONGESTION AVOIDANCE ALGORITHM
This section is missing here.
C Interaction of window adjustment with round-trip timing
This section is missing here.
D WINDOW ADJUSTMENT POLICY
This section is missing here.
References
- Aldous, D. J. Ultimate instability of exponential back-off protocol for acknowledgment based transmission control of random access communication channels. IEEE Transactions on Information Theory IT-33, 2 (Mar. 1987).
- ARPANET Working Group Requests for Comment, DDN Network Information Center. Transmission Control Protocol Specification. SRI International, Menlo Park, CA, Sept. 1981. RFC-793.
- Borrelli, R., and Coleman, C. Differential Equations. Prentice-Hall Inc., 1987.
- Chiu, D.-M., and Jain, R. Networks with a connectionless network layer; part iii: Analysis of the increase and decrease algorithms. Tech. Rep. DEC-TR-509, Digital Equipment Corporation, Stanford, CA, Aug. 1987.
- Clark, D. Window and Acknowledgement Strategy in TCP. ARPANET Working Group Requests for Comment, DDN Network Information Center, SRI International, Menlo Park, CA, July 1982. RFC-813.
- EDGE, S. W. An adaptive timeout algorithm for retransmission across a packet switching network. In Proceedings of SIGCOMM ’83 (Mar. 1983), ACM.
- FELLER, W. Probability Theory and its Applications, second ed., vol. II. John Wiley & Sons, 1971.
- HAJEK, B. Stochastic approximation methods for decentralized control of multi-access communications. IEEE Transactions on Information Theory IT-31, 2 (Mar. 1985).
- HAJEK, B., AND VAN LOON, T. Decentralized dynamic control of a multiaccess broadcast channel. IEEE Transactions on Automatic Control AC-27, 3 (June 1982).
- Proceedings of the Sixth Internet Engineering Task Force (Boston, MA, Apr. 1987). Proceedings available as NIC document IETF-87/2P from DDN Network Information Center, SRI International, Menlo Park, CA.
- INTERNATIONAL ORGANIZATION FOR STANDARDIZATION. ISO International Standard 8473, Information Processing Systems — Open Systems Interconnection — Connectionless-mode Network Service Protocol Specification, Mar. 1986.
- JACOBSON, V. Congestion avoidance and control. In Proceedings of SIGCOMM ’88 (Stanford, CA, Aug. 1988), ACM.
- JAIN, R. Divergence of timeout algorithms for packet retransmissions. In Proceedings Fifth Annual International Phoenix Conference on Computers and Communications (Scottsdale, AZ, Mar. 1986).
- JAIN, R. A timeout-based congestion control scheme for window flow-controlled networks. IEEE Journal on Selected Areas in Communications SAC-4, 7 (Oct. 1986).
- JAIN, R., RAMAKRISHNAN, K., AND CHIU, D.-M. Congestion avoidance in computer networks with a connectionless network layer. Tech. Rep. DEC-TR-506, Digital Equipment Corporation, Aug. 1987.
- KARN, P., AND PARTRIDGE, C. Estimating round-trip times in reliable transport protocols. In Proceedings of SIGCOMM ’87 (Aug. 1987), ACM.
- KELLY, F. P. Stochastic models of computer communication systems. Journal of the Royal Statistical Society B 47, 3 (1985), 379–395.
- KLEINROCK, L. Queueing Systems, vol. II. John Wiley & Sons, 1976.
- KLINE, C. Supercomputers on the Internet: A case study. In Proceedings of SIGCOMM ’87 (Aug. 1987), ACM.
- LJUNG, L., AND SÖDERSTRÖM, T. Theory and Practice of Recursive Identification. MIT Press, 1983.
- LUENBERGER, D. G. Introduction to Dynamic Systems. John Wiley & Sons, 1979.
- MILLS, D. Internet Delay Experiments. ARPANET Working Group Requests for Comment, DDN Network Information Center, SRI International, Menlo Park, CA, Dec. 1983. RFC-889.
- NAGLE, J. Congestion Control in IP/TCP Internetworks. ARPANET Working Group Requests for Comment, DDN Network Information Center, SRI International, Menlo Park, CA, Jan. 1984. RFC-896. Read it here
- PRUE, W., AND POSTEL, J. Something A Host Could Do with Source Quench. ARPANET Working Group Requests for Comment, DDN Network Information Center, SRI International, Menlo Park, CA, July 1987. RFC-1016.
- ROMKEY, J. A Nonstandard for Transmission of IP Datagrams Over Serial Lines: Slip. ARPANET Working Group Requests for Comment, DDN Network Information Center, SRI International, Menlo Park, CA, June 1988. RFC-1055.
- ZHANG, L. Why TCP timers don’t work well. In Proceedings of SIGCOMM ’86 (Aug. 1986), ACM.
Read off the page by a vision model reading the page images using olmOCR-2-7B-1025-FP8.
Read off the page by a vision model reading the page images using olmOCR-2-7B-1025-FP8. Translated into Tiếng Việt by gpt-5, against glossary version 7. Translated from the English.